Support System Outage
Incident Report for Healthy Roster
Resolved
The issue has been resolved
Posted Oct 02, 2024 - 10:13 EDT
Identified
Healthy Roster's customer support team uses SalesForce to manage cases. Salesforce is currently experiencing an outage which might result in a delay when responding to customer support requests. In the event of an extended outage we will implement our business contingency plan and provide alternate support methods.
Posted Oct 01, 2024 - 11:48 EDT